Funcion si de excel

La función si de excel es sin duda una de las mas usadas y para muchos resulta complicado su uso y comprensión, ya sea en una tabla financiera o una hoja de excel para calcular nomina, esta función resulta casi indispensable en la mayoría de los casos.

La función si de excel es tan importante que su compresión y uso para todo usuario de excel es casi obligatorio, al ser una función lógica, nos arroja cierto resultado cuando una condición o prueba lógica se cumple y otro resultado cuando esa prueba logica no se cumple.

La función SI devuelve un valor entre dos posibles valores, dependiendo de una condición indicada.

Sintaxis
=SI(prueba lógica; [valor si verdadero]; [valor si falso])

prueba lógica: es una comparación entre dos celdas usando operadores lógicos. Recuerda que los operadores lógicos son: =(igual), <(menor), >(mayor), <>(distinto), >=(mayor o igual), <=(menor o igual).
[valor si verdadero]: es el valor, celda o texto especificado a devolver si prueba lógica es verdadera.
[valor si falso]: es el valor, celda o texto especificado a devolver si prueba lógica es falsa. Los argumentos valor si verdadero y valor si falso son opcionales. Si se omiten la función SI devuelve directamente VERDADERO o FALSO.

Al ser esta una funcion condicional, hay una gran variedad de usos que le podemos dar, y se vuelve aun mas versatil al combinarla con otras funciones logicas como lo es la funcion Y o la funcion O.

Un ejemplo simple:
=SI(Y(A1>1,B1<10),”CORRECTO”,”INCORRECTO”)

Al anidar la funcion Y en el argumento de la prueba logica podemos indicar hasta 255 condiciones y todas se deben cumplir para que devuelva verdadero.

Ahora con la funcion O:

=SI(O(A1>1,B1<10),”CORRECTO”,”INCORRECTO”)

En este caso solo se debe cumplir una condicion de 255 que podemos agregar con la funcion O en el argumento prueba logica de la funcion SI.

Descargar: función si de excel

Registrare Gratis al Curso de Formulas Excel >>>

Comments

  1. ANA says

    NECESITO AYUDA CON ESTE PROBLEMA
    Si el Precio del Artículo es menor a 300; que envíe un mensaje que diga “no tiene”; sino, si el Precio del Artículo es menor a 800; la Utilidad será del 3,35% del Subtotal; caso contrario, la Utilidad será del 4,95% del Subtotal.

  2. Mari Carmen says

    ¡Hola Nolberto!
    Simplemente, agradecerte tu artículo, me ha ayudado mucho, tenía una fórmula que no conseguía cuadrarla, y tu me has dado en éste post, la solución
    ¡Muchas Gracias!
    Saludos y Feliz semana

  3. armand says

    necesito ayuda con esta formula q me sale falso cuando pongo comida no se xq ayuda =SI(C4=”ropa”;SI(A4<=5;(E4*5%);SI(A4<=10;(E4*10%);SI(A4<=11;(E4*20%);SI(C4="comida";SI(B4<=3;(E4*10%);SI(B4<=10;(E4*15%))))))))

    • says

      Le falta poner el argumento si falso… en caso de que nada se cumpla.

      =SI(C4=”ropa”;SI(A4<=5;(E4*5%);SI(A4<=10;(E4*10%);SI(A4<=11;(E4*20%);SI(C4=”comida”;SI(B4<=3;(E4*10%);SI(B4<=10;(E4*15%)))))));””)

  4. says

    Hola buen dia necesito ayuda con algo.

    tengo en una casilla un numero por ejemplo el 5 y quiero que en otra salga el nombre de este numero “cinco” pero sin utilizar la funcion “SI” existe otra posibilidad de hacer esto?

  5. Anonymous says

    Necesito Formato Condicional que me permitaidentificar con una simple mirada los registros nombre y edad de aquellos cuya edad sean mayor a un promedio que se calcula en una celda aparte. como lo hago?

  6. Anonymous says

    Hola,
    Tengo 2 columnas “A” y “B”, en la cuál están cargadas de números, en donde quiero que haga una búsqueda del 1er. número de “A” en “B”, una vez encontrado lo marque (con una letra y/o color), luego el 2do. número y así sucesivamente; de no encontrar el número continúe con el siguiente hasta finalizar.

    Saludos.-

  7. Anonymous says

    UNA PREGUNTA, Cuando tengo varios rangos como puedo hacer la formula?
    por hacer un ejemplo: si los zapatos es 1 el precio es$350, si es 2 a 3 el precio es $330 y si es de 4 a 9 el precio es $310, ¿COMO PUEDO HACER ESTA FUNCION?

  8. Anonymous says

    Hola

    Podrían ayudarme, quiero hacer una trivia en excel 2010, poner 20 imágenes una por cada hoja, cuando se acierte la primera imagen que se pase automáticamente a la hoja 2, mi pregunta ¿cual es la formula?.

    Gracias.

  9. Anonymous says

    HOLA, BUENOS DIAS QUIERO HACER UNA FORMULA, LA CUÁL VOY A TRATAR DE EXPLICAR…

    TENGO 4 HOJAS EN EXCEL, EN UNA DE ELLAS, TENGO UNA TABLA CON NUMERO Y NOMBRE DE SUCURSAL, EN OTRA HOJA TENGO UNA COLUMNA EN DONDE QUIERO QUE AL INTRODUCIR EL NUMERO DE SUCURSAL ME PONGA, EN LA COLUMNA DE LA DERECHA AUTOMATICAMENTE EL NOMBRE DE LA SUCURSAL,(A LA DERECHA DEL NOMBRE DE LA SUCURSAL VOY A INDICAR LAS OBSERVACIONES HECHAS EN ESA SUCURSAL), Y EN LA CUARTA HOJA TENGO UNA TABLA EN DONDE QUIERO LLEVAR UN CONTROL EXCLUSIVO DE UNA SUCURSAL ESPECIFICA.

    LA FORMULA ESPECIFICA(ESPERO QUE ME DE A ENTENDER) QUE NECESITO, SERIA QUE SI EN LA HOJA 2, EN LA COLUMNA DE N° DE SUCURSAL, APARECE EL N°207 (ES EL NUMERO DE LA SUCURSAL ESPECIFICA), PASE A LA HOJA 4 AUTOMATICAMENTE LA OBSERVACION INSERTADA DE LA HOJA 2… ESPERO QUE ME ENTIENDAN.
    GRACIAS

  10. says

    hola a todo tengo una duda, estoy haciendo una formula que por medio de un color (azul o Rojo) que tenga la celda me sume o me lo deje igual el valor. es decir por medio del color de la celda se puede sumar si cumple la condicion

  11. Anonymous says

    Hola, estoy haciendo una trivia de futbol en excel y me surgio una duda. Cuando las celdas que van las respuestas estan vacias, dice que la respuesta es incorrecto. Por ejemplo pongo la pregunta ¿Cuantas copas del mundo gano brasil? y la respuesta es 5, osea =SI(E25=5;”Correcto”;”Incorrecto”) pero a esa formula cuando le agrego SI(e25=” “;” “;” “) me tira error

  12. Anonymous says

    hola.. soy victoria.. tengo que hacer un ejercicio en el cual me piden que si el sueldo es menor a 4100 me indique en una celda la palabra “SI” y que si el sueldo es = o mayor a 4100 entonces que me diga “NO”.. les agradezco mucho a quienes me puedan ayudar.. y tambien debo indicar en otra celda los años de servicio partiendo de mi fecha de nacimiento hasta el dia de hoy pero no se como restar las fechas.. cualquier sugerencia o ayuda mi correo es spoilt193@hotmail.com

  13. says

    Si, gracias!. Al momento de publicar mi interrogante me dí cuenta de que con “BUSCARV” lo puedo hacer, jeje.

    Ahora, tengo otra interrogante que no vá con la función “Si” pero aprovecharé para hacerla acá mismo; y es que está relacionada con el “FORMATO CONDICIONAL”, donde quiero que, si en la celda “A1″ tiene el valor de “X” (“A1=X”), toda esa fila tenga un color/formato indicado por mi.

    De antemano gracias por su/s ayuda/s.

  14. Anonymous says

    Tengo una consulta con esta función “Si” (o no se si será con otra que deba hacerlo); y es que quiero realizar una formula anidada donde me valide que se cumpla 1 de 3 condiciones en una misma formula, es decir:
    ((Si “A”< =100 entonces "B"="C")(Si "A">100 y < ="200" entonces "B"="D")(Si "A">=201 entonces “B”=”E”))

    Como dije anteriormente, quiero que todo eso sea en una misma formula/función en la que dependiendo del valor que tenga la celda “A”, la celda “B” valdrá el valor de la celda “C”, “D” o “E”.

    Espero que me haya explicado bien y puedan ayudarme con ese problemita.

    Gracias de antemano.

    Atte.,
    KYKE KAZAN.

  15. Anonymous says

    bueno no recibi respuesta aun asi he seguido con el ejercicio y lo he comprendido un poco mas. Otra pregunta, en ese mismo ejercicio aparece un signo + arriba de la hoja y un signo – en la parte izquierda en como si fuera reglas que oculta y muestra filas y columnas como se puede hacer eso?

  16. Anonymous says

    Hola un cordial saludo, y agradecer por este sitio de antemano. Y bueno vengo a molestar con una pregunta duda, he praticado con las formulas y hay un ejercicio titulado “buscar proveedor mejor precio” contiene varias formulas esta es una de ellas que quisiera comprender más:

    =SI(ESERROR(SI(CONSULTAV($B9,base,G$8)<1,"",CONSULTAV($B9,base,G$8))),"",SI(CONSULTAV($B9,base,G$8)<1,"",CONSULTAV($B9,base,G$8)))

    bueno tengo algunas dudas al respecto, creo esta divida o formada asi

    =SI(ESERROR(SI(CONSULTAV($B9,base,G$8)<1,"",CONSULTAV($B9,base,G$8))),"", < --(PRUEBA LOGICA DEL PRIMER =SI

    “” < --- VALOR VERDADERO DEL PRIMER =SI

    SI(CONSULTAV($B9,base,G$8)<1,"",CONSULTAV($B9,base,G$8))) < --- VALOR FALSO DEL PRIMER =SI

    MI PREGUNTA ES PORQUE EN LA PRUEBLA LOGICA DEL PRIMER =SI “COMO YO LE LLAME” NO HAY UN SIGNO DE COMPARACION ASI POR DECIR COMO ESE 1000 QUE AGREGUE:

    =SI(ESERROR(SI(CONSULTAV($B9,base,G$8)<1,"",CONSULTAV($B9,base,G$8<1000))),

    Y BUENO LA SEGUNDA DUDA ES COMO FUNCIONA EN ESTA FORMULA LA FUNCION ESERROR Y PORQUE SU PARENTESIS NO SE CIERRA HASTA EL FINAL DE LA FORMULA, HE VISTO YA DOS FORMULAS CON LA FUNCION ESE ERROR ANIDADA Y SI LAS QUITO SIMPLEMENTE NO FUNCIONAN. BUENO ESPERO HABERME DADO A ENTENDER SE QUE FUI CONFUSO PERO OJALA NO TANTO, PERDON POR LA MOLESTIA Y MUCHAS GRACIAS

    yeraldo sanchez

  17. Anonymous says

    necesito hacer una formula si que me diga, los estudiantes que ganan la materia.
    2.95 Gano
    1.99 pierde
    entre 2 y 2.94 Habiita

    Yo ya la tengo con pierde y gana pero no se como colocar el rango entre 2 y 2.94 y que me diga habilita.

    Quien me puede ayudar.

    Mil gracias.

  18. Anonymous says

    Hola! Es de gran ayuda la web.

    Una cosa, podrías explicar algo mejor el ejemplo 3?? Es que no me queda muy claro lo que hace la función esa.

    saludos

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Current ye@r *